plotly v4.4.1 Release Notes

Release Date: 2019-12-10 // 3 days ago
  • [4.4.1] - 2019-12-10

    🛠 Fixed

    • 🛠 Fixed improper JSON encoding exception when the pillow module not installed #1993

Previous changes from v4.3.0

  • [4.3.0] - 2019-11-11

    ⚡️ Updated

    • ⚡️ Updated Plotly.js to version 1.51.1. See the
      plotly.js CHANGELOG
      for more information
    • 👌 Improved propagation of empty templates (#1892)
    • Update the add_annotations/add_shapes/add_images methods to no longer default to adding objects in paper coordinates. This allows plotly.js to determine the default reference frame based on context (#1888)
    • 0️⃣ Use the default template's background color for displaying color swatches (#1872). Special thanks to @joelostblom for this contribution!
    • 👌 Improved docstrings (#1835, #1837)

    ➕ Added

    • ➕ Added image trace type (plotly.js#4289, plotly.js#4307, plotly.js#4313, plotly.js#4319)
    • ➕ Added matplotlib-style plotly.express.imshow convenience function to display images and heatmaps (#1855, #1885)
    • ➕ Added matplotlib-style simple_white template (#1864). Special thanks to @joelostblom for this contribution.
    • ➕ Added support for using an externally managed orca server for image export features (#1850). Special thanks to @miriad for this contribution.
    • Added facet wrapping support to plotly express functions using the new facet_col_wrap argument (#1838)